How to resolve "This map is not compatible with this version of OpenRA"?

Information and discussion for custom maps and mods.
Post Reply
psaez
Posts: 17
Joined: Sun Jul 17, 2016 8:37 am

How to resolve "This map is not compatible with this version of OpenRA"?

Post by psaez »

Hi

I'm trying to play a map with rules, and when I try to open it in skirmish the game says "This map is not compatible with this version of OpenRA"

I tryed opeing the map on the editor, and saving it unpacked, as a folder, then, removing the rules.yaml file.

Without the rules.yaml file it stills says the same error: "This map is not compatible with this version of OpenRA"

Any ideas?

psaez
Posts: 17
Joined: Sun Jul 17, 2016 8:37 am

Re: How to resolve "This map is not compatible with this version of OpenRA"?

Post by psaez »

well, I finally solved it opening map.yaml and removing the last line with the reference to the removed rules.yaml file

freadyfish
Posts: 4
Joined: Fri Jan 19, 2024 7:51 pm
Location: Sweden
Contact:

Re: How to resolve "This map is not compatible with this version of OpenRA"?

Post by freadyfish »

Nice, but what was in the rules? Maybe they can be fixed instead so they can work as intended
Just keep modding

abcdefg30
Posts: 632
Joined: Mon Aug 18, 2014 6:00 pm

Re: How to resolve "This map is not compatible with this version of OpenRA"?

Post by abcdefg30 »

"debug.log" in the logs directory might contain a hint when the map fails to load. Alternatively use the utility shipped with the game to check the maps for lint errors, using the "--check-yaml" command: https://github.com/OpenRA/OpenRA/wiki/Utility

Post Reply