RA quits unexpected when custom map is loaded

Information and discussion for custom maps and mods.
Post Reply
fbn
Posts: 1
Joined: Fri May 22, 2020 9:24 pm

RA quits unexpected when custom map is loaded

Post by fbn »

Code: Select all

OpenRA engine version release-20200503
Red Alert mod version release-20200503
on map 63a118f9df5f28bc680a9731792cd1dfabfa47bf (castle by FBN).
Date: 2020-05-26 01:29:07Z
Operating System: OSX (Unix 19.4.0.0)
Runtime Version: Mono 6.4.0.198 (2019-06/fe64a4765e6 Wed Sep 18 14:14:51 EDT 2019) CLR 4.0.30319.42000
Exception of type `System.ArgumentException`: An item with the same key has already been added. Key: mpspawn castle
  at System.Collections.Generic.Dictionary`2[TKey,TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) [0x0015a] in <b814b509d4ad406fb40c6c93e38929e7>:0 
  at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) [0x00000] in <b814b509d4ad406fb40c6c93e38929e7>:0 
  at OpenRA.Primitives.SpatiallyPartitioned`1[T].Add (T item, OpenRA.Primitives.Rectangle bounds) [0x00008] in <d572d317940047d2a5a305d62d990530>:0 
  at OpenRA.Mods.Common.Traits.EditorActorLayer.Add (OpenRA.Mods.Common.Traits.EditorActorPreview preview, System.Boolean initialSetup) [0x0001c] in /Users/travis/build/OpenRA/OpenRA/OpenRA.Mods.Common/Traits/World/EditorActorLayer.cs:134 
  at OpenRA.Mods.Common.Traits.EditorActorLayer.Add (System.String id, OpenRA.ActorReference reference, System.Boolean initialSetup) [0x00030] in /Users/travis/build/OpenRA/OpenRA/OpenRA.Mods.Common/Traits/World/EditorActorLayer.cs:125 
  at OpenRA.Mods.Common.Traits.EditorActorLayer.WorldLoaded (OpenRA.World world, OpenRA.Graphics.WorldRenderer wr) [0x000d6] in /Users/travis/build/OpenRA/OpenRA/OpenRA.Mods.Common/Traits/World/EditorActorLayer.cs:74 
  at OpenRA.World.LoadComplete (OpenRA.Graphics.WorldRenderer wr) [0x000c4] in <d572d317940047d2a5a305d62d990530>:0 
  at OpenRA.Game.StartGame (System.String mapUID, OpenRA.WorldType type) [0x000ce] in <d572d317940047d2a5a305d62d990530>:0 
Any idea how to fix this? I cant load this map in the map editor and modify it.

abcdefg30
Posts: 410
Joined: Mon Aug 18, 2014 6:00 pm

Re: RA quits unexpected when custom map is loaded

Post by abcdefg30 »

Hm, your best bet is probably opening the "map.yaml" file of the map (open the .oramap like a zip if you haven't saved it unpacked), finding the actors that have the same name and then delete or rename one of them. (The error message at least suggests there are two or more actors with the same name/key.)

Post Reply