Lua 5.1. Or more new version?

Lua

Information and discussion for custom maps and mods.
Post Reply
Adrian
Posts: 47
Joined: Wed Feb 12, 2020 5:44 pm

Lua 5.1. Or more new version?

Post by Adrian »

I read article here about compiling.
https://github.com/OpenRA/OpenRA/wiki/Compiling

I can see there, that recommended version of Lua is 5.1.
What if to install newer version? Does it matter?

The current version is Lua 5.4.

abcdefg30
Posts: 430
Joined: Mon Aug 18, 2014 6:00 pm

Re: Lua 5.1. Or more new version?

Post by abcdefg30 »


Adrian
Posts: 47
Joined: Wed Feb 12, 2020 5:44 pm

Re: Lua 5.1. Or more new version?

Post by Adrian »

Thank you! Now I understand.

Another question:
Are there any plans to rewrite that "Eluant" in new Lua?

Problem.
It looks like Lua 5.1. absolutly has no support of non-ASCII characters. So user cannot use not Latin symbols (from different languages).

I cannot even write comment in Lua file with non-ASCII characters, for example.

abcdefg30
Posts: 430
Joined: Mon Aug 18, 2014 6:00 pm

Re: Lua 5.1. Or more new version?

Post by abcdefg30 »

There are ideas to move to another library (which e.g. would also help with savegames). We first need to sort some other internals out though (e.g. the move to .NET core 5.)

Post Reply