[RA][Semi-TC] CnC: Crisis

Information and discussion for custom maps and mods.
User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Cmd. Matt wrote:
secret wrote: Matt, is there any way I could help you?
Fix up https://github.com/Mailaender/OpenRA/compare/shpviewer It crashes hard with native stacktrace on Mono and only builds with many compiler warnings. There are also some parts of the codes where exceptions are simply catched and swallowed. This needs lot's of work to make it's way through Chris' code review into OpenRA.
...right. That's a bit too complicated for me to handle, sadly. My programming knowledge is quite limited.

Matt
Posts: 1039
Joined: Tue May 01, 2012 12:21 pm
Location: Germany

Post by Matt »

Don't expect something to happen soon. I am also overstrained with this, too. For the time being have a look at http://openra-modding.tumblr.com/ to convert your files.

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Right, got some issues with the SHP conversion, which neither XCC Mixer or OpenRA.Utility are able to do.

I have 32 .PNG files (WITHOUT indexed palette) which are basically the same frame repeating itself 32 times, with the names "fact 0000.png", "fact 0001.png" ... "fact 0031.png", which I am not able to convert. NOT interlaced.

When using OpenRA Utility I insert "OpenRA.Utility --shp fact 0000.png 144" (since the file is 144x72").

So I went again to XCC Mixer.
If I use XCC Mixer, it doesn't load up any palette at all. If I use .PNG, it isn't able to render a usable file.

What am I supposed to do? I know there are these palettes here http://www.sleipnirstuff.com/forum/view ... 62f5a5265c

Is there anything I am missing?
Another thing: what color ought the background to be? Blue or black?
Also, I'm doing all this with a building, NOT a cameo.

Matt
Posts: 1039
Joined: Tue May 01, 2012 12:21 pm
Location: Germany

Post by Matt »

You need to combine it into one indexed PNG with frame [1][2][3].. pasted next to each other for OpenRA.Utility.exe

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Thanks! Eventually solved the conversion issues, but right now I get some weird errors.

My building is 144 (horizontally) by 72 (vertically), and somehow I can't get it ingame.
That's 5x3, right?
I have the following code:

Code: Select all

FACT:
	Inherits: ^Building
	Building:
		Power: 0
		Footprint: xxxxx xxx xxxxx
		Dimensions: 5,3
	Health:
		HP: 1000
	Armor:
		Type: Heavy
	RevealsShroud:
		Range: 5
	Bib:
	Production:
		Produces: Building,Defense
	IronCurtainable: 
	Valued:
		Cost: 2500
	Tooltip:
		Name: Construction Yard
	CustomSellValue:
		Value: 2500
	BaseBuilding:
	Transforms:
		IntoActor: mcv
		Offset:1,1
		Facing: 96
	ProductionBar:
		
Is there anything I am missing?

EDIT: Here's the SHP image as well (multiple frames repeating):
Attachments
fact.png
fact.png (13.74 KiB) Viewed 3998 times

Matt
Posts: 1039
Joined: Tue May 01, 2012 12:21 pm
Location: Germany

Post by Matt »

144x72 px is 6x3 with a TileSize of 24. Try adjusting your code:

Code: Select all

   Building:
      Power: 0
      Footprint: xxxxxx xxxxxx xxxxxx
      Dimensions: 6,3 

raminator
Posts: 106
Joined: Tue Mar 15, 2005 6:31 pm
Location: Stuttgart

Post by raminator »

building looks nice =)
good luck with your project

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Thanks raminator! Also thanks for the help provided a couple weeks/months ago. :D

Some more work + conversion work is finally going nicely for me.

Question: Is there a way I can replace the animation that goes in the background in the RA mod with a static image?
Attachments
morework.png
morework.png (46.34 KiB) Viewed 3739 times

Matt
Posts: 1039
Joined: Tue May 01, 2012 12:21 pm
Location: Germany

Post by Matt »

Change the animation length in sequences.yaml to 1.

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Update: New UI:

Image

raminator
Posts: 106
Joined: Tue Mar 15, 2005 6:31 pm
Location: Stuttgart

Post by raminator »

looking good =)

bellator
Posts: 90
Joined: Wed Sep 28, 2011 12:22 am

Post by bellator »

good menu. the way it fades into the black is appropriately pretentious.

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Thanks guys.

If earlier I was presenting you the Internationale Refinery, right now I'm presenting you the Tesla Powerplant for the Internationale.
Attachments
socute.png
socute.png (33.77 KiB) Viewed 3572 times

User avatar
secret
Posts: 62
Joined: Fri Aug 03, 2007 1:53 pm

Post by secret »

Slight bump with a comparison of currently done buildings with what's left to do. Why do I post this? People have been complaining about the angles, however I don't want to worry about them, since everything looks pretty fine IMO.
Attachments
comparison.png
comparison.png (197.04 KiB) Viewed 3547 times

User avatar
BaronOfStuff
Posts: 438
Joined: Sun May 22, 2011 7:25 pm

Post by BaronOfStuff »

While they do look good, there's no denying that the angle is somewhat 'off' on the new stuff. It's difficult to explain, but they appear to be somewhat 'tilted' toward the viewer. It's easiest to notice by comparing the STEK to the newer structures.

Post Reply