The Playtest Bug

Discussion about the game and its default mods.
Post Reply
Lorrydriver
Posts: 64
Joined: Thu Dec 01, 2016 3:55 am

The Playtest Bug

Post by Lorrydriver »

Hey,

I'm aware that we already got a playtest thread, but I believe this matter is very urgent and needs to be addressed asap.

I've played quite a few games on the playtest now and unfortunately it's almost impossible to make out whether the intentional changes are good or not. The reason is that there's a nasty bug that makes your units not acquire their targets as they're supposed to and therefore they start shooting way too late. This is especially annoying if you're trying to fight air units with rocket soliders, they'll shoot 2-3 seconds too late. It also makes it impossible to attack bases with static defenses or kill apcs before they got a million crushes. We've heard a lot of negative feedback because of the stances but that may be just because the game is so bugged on the playtest right now. We need to get that bug fixed and then retest and re-evaluate the actual changes. The playtest right now is in an unplayable state im afraid.
Attachments
OpenRA-2017-08-15T205853Z.orarep
There's a couple of examples in there, but take a look at my natural expansion minute 18 theres a yak seen by my rocket soliders but they don't even start shooting. Around 18:50 there's a MiG flying in clearly in my vision and the rockets which I even put
(1.1 MiB) Downloaded 65 times

User avatar
AoAGeneral1
Posts: 597
Joined: Wed Apr 29, 2015 6:11 pm

Post by AoAGeneral1 »

This issue has been in ORA since nearly 7 releases ago. (About 4 years.) So this particular issue isn't new. I believe the devs are also aware of this as well but it involves a scan go cell by cell to target units while on the move. (Devs would know more specific details of this problem.)

User avatar
anjew
Posts: 527
Joined: Sat Nov 08, 2014 4:16 am

Re: The Playtest Bug

Post by anjew »

Lorrydriver wrote: -snip-
Pretty sure this is also the bug that causes recon bikes to either fire 1 rocket or just constantly try to acquire a moving target.
Image

Lorrydriver
Posts: 64
Joined: Thu Dec 01, 2016 3:55 am

Post by Lorrydriver »

Well, that bug certainly doesn't occur in RA if you use stop micro, in playtest it does.

r0b0v
Posts: 37
Joined: Sun Apr 16, 2017 2:30 pm

Post by r0b0v »

It could be fixed here https://github.com/OpenRA/OpenRA/pull/13830, see the referenced issues. It is already merged and will be included in next playtest.

User avatar
Sleipnir
Posts: 805
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Post by Sleipnir »

You can try a test build of the current tip of the prep-1707 branch to see if this has been fixed already for the next playtest.

https://ci.appveyor.com/project/OpenRA/ ... /artifacts

User avatar
Sleipnir
Posts: 805
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Post by Sleipnir »

Lorrydriver, can you please test the linked build and report back whether the issue has been fixed?

Post Reply