Issues with OS SHP Builder OpenRA Utility

Information and discussion for custom maps and mods.
Post Reply
devilslayersbane
Posts: 20
Joined: Fri Jan 15, 2016 5:42 am

Issues with OS SHP Builder OpenRA Utility

Post by devilslayersbane »

So, I've been working on updating my mod (which is slightly buried, but that's my own fault for not updating it). That being said, I've been getting bogged down because I want to add my own custom sprites to it. I have a .png file ready to be converted, however, both SHP Builder and OpenRA Utility refuse to convert the sprite. I exporeted the images to .png's then put them together via paint.net. Now, it's not really a naming issue, as I've used SHP Builder to convert .png's to SHP's for cameo's, but never full 32 facing sprites. I know that SHP Builder can do the color indexing (which paint.net can't do on it's own), however the only time it build's a sprite is when it meshes all of the frames together. (kinda). Images to come soon.

If anyone can help me with this issue, I do have the png located here.

User avatar
Graion Dilach
Posts: 274
Joined: Fri May 15, 2015 5:57 pm

Post by Graion Dilach »

SHP Builder cannot handle spritesheets, and can only import frames - which is why it requires the filename 0000 syntax. Aka, first frame has 0000, second 0001 etc etc..

The sole way I'm aware a spritesheet can be converted to an SHP is to get XCC Mixer, set up it's directory to the OpenRA content directories then select the correct palette, right-click on the image->Clipboard->Copy and then Clipboard->Paste as SHP when you get a window to specify all size-related properties of the result (frame sizes and count).
Image
Image
Image
AS Discord server: https://discord.gg/7aM7Hm2

Post Reply