missing msbuild command on gentoo

instructions for gentoo are incomplete: user@host ~/OpenRA $ make OpenRA requires the 'msbuild -verbosity:m -nologo' tool provided by Mono >= 5.18. make: *** [Makefile:87: all] Error 1

Discussion about the game and its default mods.
Post Reply
engrenage
Posts: 11
Joined: Thu Aug 05, 2021 7:56 pm

missing msbuild command on gentoo

Post by engrenage »

hoping someone can provide guidance

engrenage
Posts: 11
Joined: Thu Aug 05, 2021 7:56 pm

Re: missing msbuild command on gentoo

Post by engrenage »

looks like I fixed it with

# emerge dotnet-sdk-bin


and having

#!/bin/bash
dotnet msbuild $*

executable in /usr/local/bin/msbuild


maybe an alias would have worked just fine.


doc still needs to be updated (or makefile or however this goes, not familiar with this)

User avatar
Sleipnir
Posts: 867
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Re: missing msbuild command on gentoo

Post by Sleipnir »

https://github.com/OpenRA/OpenRA/blob/bleed/INSTALL.md has the compilation instructions for all platforms. Please note in particular the comment
We recommend using .NET 5 when possible, as Mono is poorly packaged by most Linux distributions (e.g. missing the required msbuild toolchain), and has been deprecated as a standalone project.
Builds from the last few months use dotnet by default where no workarounds are needed, so I expect that you were trying to compile the previous stable release (which predates the change to net5 by default).

Post Reply