OpenRA Crashes on Startup

OpenRA canot start

Discussion about the game and its default mods.
Post Reply
Hetzer
Posts: 4
Joined: Sat Jul 11, 2020 9:05 am

OpenRA Crashes on Startup

Post by Hetzer »

I have a Lenovo R61 machine with a Mobile Intel 965 Video Chipset running Windows 7 Ultimate 32bit.

OpenRA completed installation but when I try to run it it crashes no matter what compatibility mode I select.

Please find below the exception/crash log. Any ideas on how we can solve this issue?

OpenRA engine version release-20200503
Date: 2020-07-11 08:46:08Z
Operating System: Windows (Microsoft Windows NT 6.1.7601 Service Pack 1)
Runtime Version: .NET CLR 4.0.30319.42000
Exception of type `System.InvalidOperationException`: Failed to initialize platform-integration library. Check graphics.log for details.
at OpenRA.Game.Initialize(Arguments args)
at OpenRA.Game.InitializeAndRun(String[] args)
at OpenRA.WindowsLauncher.RunGame(String[] args)

graphics.log

System.InvalidProgramException: Failed to initialize low-level OpenGL bindings. GPU information is not available. ---> System.ArgumentNullException: Value cannot be null.
Parameter name: ptr
at System.Runtime.InteropServices.Marshal.GetDelegateForFunctionPointer(IntPtr ptr, Type t)
at OpenRA.Platforms.Default.OpenGL.Bind[T](String name)
at OpenRA.Platforms.Default.OpenGL.Initialize(Boolean preferLegacyProfile)
--- End of inner exception stack trace ---
at OpenRA.Platforms.Default.OpenGL.Initialize(Boolean preferLegacyProfile)
at OpenRA.Platforms.Default.Sdl2GraphicsContext.InitializeOpenGL()
at OpenRA.Platforms.Default.Sdl2PlatformWindow..ctor(Size requestEffectiveWindowSize, WindowMode windowMode, Single scaleModifier, Int32 batchSize, Int32 videoDisplay, GLProfile requestProfile)
at OpenRA.Platforms.Default.DefaultPlatform.CreateWindow(Size size, WindowMode windowMode, Single scaleModifier, Int32 batchSize, Int32 videoDisplay, GLProfile profile)
at OpenRA.Renderer..ctor(IPlatform platform, GraphicSettings graphicSettings)
at OpenRA.Game.Initialize(Arguments args)
System.InvalidProgramException: Failed to initialize low-level OpenGL bindings. GPU information is not available. ---> System.ArgumentNullException: Value cannot be null.
Parameter name: ptr
at System.Runtime.InteropServices.Marshal.GetDelegateForFunctionPointer(IntPtr ptr, Type t)
at OpenRA.Platforms.Default.OpenGL.Bind[T](String name)
at OpenRA.Platforms.Default.OpenGL.Initialize(Boolean preferLegacyProfile)
--- End of inner exception stack trace ---
at OpenRA.Platforms.Default.OpenGL.Initialize(Boolean preferLegacyProfile)
at OpenRA.Platforms.Default.Sdl2GraphicsContext.InitializeOpenGL()
at OpenRA.Platforms.Default.Sdl2PlatformWindow..ctor(Size requestEffectiveWindowSize, WindowMode windowMode, Single scaleModifier, Int32 batchSize, Int32 videoDisplay, GLProfile requestProfile)
at OpenRA.Platforms.Default.DefaultPlatform.CreateWindow(Size size, WindowMode windowMode, Single scaleModifier, Int32 batchSize, Int32 videoDisplay, GLProfile profile)
at OpenRA.Renderer..ctor(IPlatform platform, GraphicSettings graphicSettings)
at OpenRA.Game.Initialize(Arguments args)

User avatar
Sleipnir
Posts: 826
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Re: OpenRA Crashes on Startup

Post by Sleipnir »

OpenRA requires your GPU to support OpenGL 2.1 or greater, and Intel/Microsoft do not support this for your system. It should work if you install Linux (which does provide basic driver support), but performance is probably not going to be very good.

Hetzer
Posts: 4
Joined: Sat Jul 11, 2020 9:05 am

Re: OpenRA Crashes on Startup

Post by Hetzer »

This is unfortunate news since this system is more or less a strategy game machine running Red Alert 2, C&C Generals Zero Hour; Battlezone and CnCNET with no issues.

Performance is not really an issue in RA 1 on a Core2Duo.

Is there a way to emulate/force OpenGL 2.1 on Intel 965 chipsets besides running Linux for it?

Matthias0815
Posts: 2
Joined: Fri Jan 31, 2020 10:52 am

Re: OpenRA Crashes on Startup

Post by Matthias0815 »

Hi,

The same here. I use a Lenovo Miix 310. Which was the last version i can use?

Post Reply