Disabling Helipads in CNC Map Rules

Information and discussion for custom maps and mods.
Post Reply
User avatar
RadicalEdward2
Posts: 80
Joined: Sat Feb 11, 2017 12:34 am
Location: NJ

Disabling Helipads in CNC Map Rules

Post by RadicalEdward2 » Mon Apr 24, 2017 4:44 am

Can helipads (HPAD) be disabled in a map's rules in CNC like they can in RA?

I tried using this:

Code: Select all

Rules:
    HPAD:
        Buildable:
            Prerequisites: ~disabled
And it crashed the game.
I wanted to update my remake of Field from Renegade to make it more like the original map without having to set the match to a lower tech level.

If anyone wants see what they can do, I attached the oramap file.
Attachments
field v1.5.oramap
(19.67 KiB) Downloaded 64 times

User avatar
KOYK_GR
Posts: 52
Joined: Fri Aug 26, 2011 12:46 pm

Post by KOYK_GR » Wed Apr 26, 2017 2:55 am

I think you can just remove the "Buildable" trait and you are ok

User avatar
RadicalEdward2
Posts: 80
Joined: Sat Feb 11, 2017 12:34 am
Location: NJ

Post by RadicalEdward2 » Wed Apr 26, 2017 8:21 pm

KOYK_GR wrote: I think you can just remove the "Buildable" trait and you are ok
I tried this:

Code: Select all

Rules:
    HPAD:
            Prerequisites: ~disabled
But removing Buildable removed the map from the list altogether.

Code: Select all

Rules:
    HPAD:
        Buildable: False
Crashed the game.

Blackened
Posts: 292
Joined: Sat May 21, 2016 6:27 pm

Post by Blackened » Wed Apr 26, 2017 11:55 pm

Make sure your indentations are correct. I did a quit test and it worked for me.

Murto the Ray
Posts: 486
Joined: Mon Nov 10, 2014 4:34 pm

Post by Murto the Ray » Thu Apr 27, 2017 6:20 am

Code: Select all

Rules:
    HPAD:
        -Buildable:
This is how traits are removed throughout the OpenRA codebase. I don't know if your method works but this is how it's done everywhere else.

User avatar
RadicalEdward2
Posts: 80
Joined: Sat Feb 11, 2017 12:34 am
Location: NJ

Post by RadicalEdward2 » Fri Apr 28, 2017 5:03 pm

Ooooh! Okay! I see what happened. Blackened was right.
I forgot to skip a line before adding the Rules. So the Rules were bundled in with the actors.
Thanks guys!

Post Reply