Map Install Issue

Discussion about the game and its default mods.
Post Reply
zinc
Posts: 657
Joined: Sun Feb 09, 2014 3:46 pm

Map Install Issue

Post by zinc » Fri Nov 17, 2017 3:36 am

Some of the maps don't seem to be downloading. Pictures (map design) aren't showing on the resources site for the maps in question (I think), and if you click on the map you don't get taken to the page for the map, but rather directed elsewhere.

Reason for this?

User avatar
avalach21
Posts: 213
Joined: Mon Aug 10, 2015 8:01 pm

Re: Map Install Issue

Post by avalach21 » Fri Nov 17, 2017 4:02 am

zinc wrote: Some of the maps don't seem to be downloading. Pictures (map design) aren't showing on the resources site for the maps in question (I think), and if you click on the map you don't get taken to the page for the map, but rather directed elsewhere.

Reason for this?
This has always happened from time to time but I will say that it seems to be occurring more frequently lately.

zinc
Posts: 657
Joined: Sun Feb 09, 2014 3:46 pm

Post by zinc » Fri Nov 17, 2017 12:51 pm

There have always been some in-game downloading problems yes.

But I'm not just talking about that-- when you go to the resources site the pages are messed up there also, which seems to be a recent thing.

User avatar
avalach21
Posts: 213
Joined: Mon Aug 10, 2015 8:01 pm

Post by avalach21 » Fri Nov 17, 2017 2:48 pm

zinc wrote: There have always been some in-game downloading problems yes.

But I'm not just talking about that-- when you go to the resources site the pages are messed up there also, which seems to be a recent thing.
Oh good call, maybe that's somehow related to the seemingly increasing issue within the game client

User avatar
Sleipnir
Posts: 770
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Post by Sleipnir » Thu Nov 23, 2017 9:03 pm

It turns out that the critical piece of information about the ingame installation bug (that it shows the download error dialog, but the retry button doesn't do anything) was commonly known in the player community, but nobody mentioned this detail in the bug tracker.

Once somebody mentioned this it took approximately 5 minutes to identify the bug and work out the fix, which will be shipped in the next playtest.
This could have been fixed many months ago if somebody had reported the bug details upstream :(

User avatar
Clockwork
Posts: 314
Joined: Fri Jan 06, 2017 3:50 am
Contact:

Post by Clockwork » Thu Nov 23, 2017 9:52 pm

Until that release comes the best solution is wait at least 10 seconds before clicking to install the map, works every time for me. Or rip it straight from the resource center.

zinc
Posts: 657
Joined: Sun Feb 09, 2014 3:46 pm

Post by zinc » Thu Nov 23, 2017 10:01 pm

I don't think this is the same issue as the in-game installation bug. I mean it results in you having an equivalent problem to that, but it seems to be something more.

This is an issue where you can't go to the resource centre for the map either. (Although I haven't checked in the last few days if it still isn't working.)

User avatar
Sleipnir
Posts: 770
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Post by Sleipnir » Thu Nov 23, 2017 11:12 pm

The two issues are distinct but related: when the resource center glitch occurs ingame it will trigger the map download failed state, which is bugged and can only be cleared by restarting the game.

The resource center glitch is likely related to website load, and so if everyone clicks install at the same time (e.g. when a new custom map is selected on a server) then it is very likely to trigger the failures. Waiting a bit spreads out the load and reduces the chance of triggering the glitch there. It probably will help in many cases, but is by no means guaranteed.

We don't have anybody to maintain the resource center code, so the problems there aren't likely to be fixed until an external contributor can research the code and submit a fix.

User avatar
netnazgul
Posts: 442
Joined: Mon Jul 10, 2017 7:32 am
Location: Minsk
Contact:

Post by netnazgul » Fri Nov 24, 2017 4:21 am

Sleipnir wrote: This could have been fixed many months ago if somebody had reported the bug details upstream :(
Sleipnir wrote: We don't have anybody to maintain the resource center code, so the problems there aren't likely to be fixed until an external contributor can research the code and submit a fix.
The latter was assumed as well as the long-standing issues with the recourse center, which is likely to be bugged every time you access it, that's why probably noone bothered to even think this is not exactly RC issue?

User avatar
Sleipnir
Posts: 770
Joined: Wed Apr 10, 2002 11:52 pm
Contact:

Post by Sleipnir » Sat Dec 09, 2017 11:55 pm

I think I have fixed the problem with the resource center. I hope you are all happy.

noobmapmaker
Posts: 1086
Joined: Wed Dec 10, 2014 11:59 am

Post by noobmapmaker » Mon Dec 11, 2017 6:45 am

Sweet!
Playlist with ALL games of the Dark Tournament Youtube.com/CorrodeCasts
Consider supporting OpenRA by setting a bounty or by donating for a server

User avatar
Clockwork
Posts: 314
Joined: Fri Jan 06, 2017 3:50 am
Contact:

Post by Clockwork » Mon Dec 11, 2017 9:02 am

Thank you glorious developers :bana: :bana: :bana: :bana: :bana:

eskimo
Posts: 316
Joined: Tue Jan 17, 2017 9:59 pm

Post by eskimo » Mon Dec 11, 2017 10:31 pm

Nice, top work :D

zinc
Posts: 657
Joined: Sun Feb 09, 2014 3:46 pm

Post by zinc » Wed Dec 13, 2017 5:25 am

Sleipnir wrote: I think I have fixed the problem with the resource center. I hope you are all happy.
Thanks for your efforts but...

When I checked, various maps did indeed seem to have been fixed, but not all of them. I originally noticed this issue when people couldn't download original doubles (better than the official version imo), and so I uploaded a copy of that map myself to see if that would fix things and enable in-game downloading. It didn't fix things and that map was (and still is when I checked) messed up on the resource site.

Post Reply