Compiling OpenRA on Win7 x64

What am I doing wrong?

Discussion about the game and its default mods.
Post Reply
reaperrr
Posts: 17
Joined: Wed Dec 17, 2003 3:35 pm

Compiling OpenRA on Win7 x64

Post by reaperrr » Sat Oct 27, 2012 10:37 am

I've tried it multiple times, but there are always the same symptoms:

1) When I compile for the first time from a freshly cloned rep, VE C# 2010 always gives me error messages about how unsafe code in Textures.cs can only be compiled with /unsafe. Un-checking and re-checking the allow unsafe code option in OpenRA.Renderer.SdlCommon properties gets rid of those, but I find it odd that I get this error to begin with.

2) After that, it does compile, but with two warnings that basically say the same thing, the ICSharpCode.SharpZipLib wasn't found. Not sure whether that's normal.

3) The compiled build doesn't start at all, no matter what I try.

4) Copying the compiled OpenRA.Mod.RA.dll - which is about 19 KB smaller than the 20121019 releases' dll, which is fishy enough - to a fresh install of the latest public release shows a very odd behavior, D2K starts and seems to work fine (though I haven't played it extensively), RA and CNC crash when trying to load them.

Originally I had thought it was the additional weapon slots I had implemented in an earlier attempt, but those actually worked just fine in D2K. And like I said, I tried again with a fresh compile straight from a fresh, unmodified source, no difference there.


I'm at a loss. I have no previous experience with programming or compiling (except for multiple failed attempts to compile OpenRA or Ares over the last few months), so I have no idea what the problem might be.

Since I've managed to compile a sort-of-working dll it doesn't seem to be a fundamental issue like me being too dumb to do sh*t, but still... something is wrong, and I want to know what it is, because it frustrates me to no end.

Post Reply